导航:首页 > 股市基金 > 霸王指标公式源码

霸王指标公式源码

发布时间:2023-09-20 17:40:21

『壹』 通达信选股公式源码

你好,通达信选股公式源码如下。
次日涨停
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=交叉(C,REF(W3,1));
W4和计数(W4,5)=1;
黄转紫选股
差异:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差异,9);
MACD:=(DIFF-DEA)*2;
紫柱:MACD<0和MACD>REF(MACD,1)和REF(MACD,1)低位金叉选股
差异:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差异,9);
MACD:=(DIFF-DEA)*2;
低位金叉:交叉(差异,DEA)和差异<-0.1;
二次金叉选股
差异:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差异,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=计数(交叉(差异,数据包络分析),BARSLAST(数据包络分析>=0));
二次金叉:交叉(差异,DEA)和DEA<0,计数(JCCOUNT=2,21)=1;
绝地反弹
(1)
VAR1:=参考值(低,1);
VAR2:=SMA(ABS(低VAR1),13,1)/SMA(最大值(低VAR1,0),13,1)*100;
VAR3:=EMA(如果(关闭*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(低,34);
VAR5:=HHV(VAR3,34);
VAR6:=如果(LLV(低,55),1,0);
VAR7:=EMA(如果(低)<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(低,2)*0.96;
XL2:=MA(低,26)*0.85;
XL3:=REF(XL1,1)启动:=如果(XL3,0,VAR7*3),则为红色;
XG:启动>25;
(2)
倒退((参考(关闭,1)<参考(打开,1)和
关闭>打开和ABS(关闭参考(关闭,1))/关闭<0.002),2);
A2:=过滤器(A1<=V3,10);
ND资本<300000000
REF(V,1)=LLV(V,4)和V>=REF(V,1)
HHV(V,3)=参考(V,1)和HHV(V,5)=参考(V,1)和HHV(V,21)=参考(V,1)
和V>=REF(V,1)
01>0,T02>0;
1.三线粘合
M:=1;
M5:=MA(闭合,5);
M10:=MA(闭合,10);
M20:=MA(闭合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1,A2和A3,C>O和V>REF(V,1),资本<=300000000;
2.三条线粘合
N1:=5;N2:=10;N3:=20;M:=1;
MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
最大值(MA1,最大值(MA2,MA3))/MIN(MA1,最小值(MA2,MA3))<1+0.01*M
C>O和V>REF(V,1)和财务(7)<=300000000
A3及资本<=300000000;
3.均线粘合
M:=1;
M5:=MA(闭合,5);
M10:=MA(闭合,10);
M20:=MA(闭合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.01*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1以及A2和A3;
3.金叉选股指标
快线:=均线(均线)(均线(收盘,2,2,2),;
慢线:=EMA(参考(快线,1),2);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
交叉(快线,慢线) 和C>O和
五> =MA(V,21)和V>REF(V,1),资本<=300000000;

『贰』 赢在龙头的指标 个股资金强弱 源码 哪位知道!

{修改以后,通达信已通过测试}

20,POINTDOT;
50,POINTDOT;
80,POINTDOT;
个股线:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,;
大盘线:MA(FORCAST(个股线,20),6),,COLORGREEN,;

YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 -

10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
MA75:=MA(CLOSE,144);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);

LC:=REF(C,1);
K9:=SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1);
D9:=SMA(K9,3,1);
J9:=3*K9-2*D9;
VAR1:=DYNAINFO(17)*REF(MA(V,5),1);
VAR2:=DYNAINFO(7)=C AND DYNAINFO(10)=AMOUNT;
VAR3:=IF(DYNAINFO(7)=C AND DYNAINFO(10)=AMOUNT,VAR1,VAR2);
预量:=IF(V>=VAR3 AND PERIOD=5,V,VAR3);
TT:=240/FROMOPEN;
比:=TT;
比1:=预量/V;
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,(DYNAINFO(23)*比),(IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8))));
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,(DYNAINFO(22)*比),(IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7))));
买盘1:=DYNAINFO(23)*比1;
卖盘1:=DYNAINFO(22)*比1;
MFI:=(HIGH-LOW)*1000000/(VOL*比);
XXX:=EMA((C-LLV(L,11))/(HHV(H,25)-LLV(L,11))*4,8)+1;
XX:=IF(1=1,POW(XXX,2)-10,DRAWNULL);
DRAWTEXT((CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,4),COLORFF00FF;
DRAWTEXT((CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,5),COLORFF00FF;
DRAWTEXT((CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,6),COLORFF00FF;
DRAWTEXT((CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,7),COLORFF00FF;
DRAWTEXT((CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,8),COLORYELLOW;
DRAWTEXT((CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,9),COLORYELLOW;
DRAWTEXT((CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,10),COLORYELLOW;
DRAWTEXT((CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,70,11),COLORYELLOW;
DRAWTEXT((CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,12),COLOR00FFFF;
DRAWTEXT((CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,13),COLORYELLOW;
DRAWTEXT((CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,14),COLORYELLOW;
DRAWTEXT((CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,15),COLORYELLOW;
DRAWTEXT((CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,16),COLORYELLOW;
DRAWTEXT((CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,17),COLORFFFF00;
DRAWTEXT((CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,18),COLORFFFF00;
DRAWTEXT((CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0)))=1 AND (CLOSE < 200) AND CURRBARSCOUNT=59,60,19),COLORFFFFFF;
DRAWTEXT((CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,20),COLOR00FF00;
DRAWTEXT((CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,21),COLORFF00FF;
DRAWTEXT((CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,22),COLORAAAAAA;
DRAWTEXT((CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,23),COLORFF0000;
DRAWTEXT((CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,24),COLOR00FFFF;
DRAWTEXT((CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,25),COLOR00FF00;
DRAWTEXT((CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,26),COLORFFFFFF;
DRAWTEXT((CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0))) AND (CLOSE >200) AND CURRBARSCOUNT=59,50,27),COLORFFFFFF;
DRAWTEXT(CONST(MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1)) AND CURRBARSCOUNT=59,40,28),COLORFFFFFF;
DRAWTEXT(CONST(MFI<REF(MFI,1)AND VOL*比<REF(VOL,1)) AND CURRBARSCOUNT=59,40,29),COLORGREEN;
DRAWTEXT(CONST(MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1)) AND CURRBARSCOUNT=59,40,30),COLORGREEN;
DRAWTEXT(CONST(MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1)) AND CURRBARSCOUNT=59,40,31),COLORYELLOW;
DRAWTEXT(CONST((卖盘+买盘)/REF(VOL,1)>2) AND CURRBARSCOUNT=59,30,32),COLORGREEN;
DRAWTEXT(CONST(REF(VOL,1)/(卖盘+买盘)>1.5) AND CURRBARSCOUNT=59,30,33),COLORYELLOW;
DRAWTEXT(CONST((卖盘-买盘)/买盘>0.4) AND CURRBARSCOUNT=59,20,34),COLORGREEN;
DRAWTEXT(CONST((买盘-卖盘)/卖盘>0.4) AND CURRBARSCOUNT=59,20,35),COLORYELLOW;

DRAWTEXT(CONST(IF(预量=LLV(预量,10),1,0)) AND CURRBARSCOUNT=59,10,36),COLOR00FF00;
DRAWTEXT(CONST(IF(预量=LLV(预量,10) AND J9<70,1,0)) AND CURRBARSCOUNT=59,10,37),COLOR00FF00;
DRAWTEXT(CONST(IF(C>LC AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND C>MA(C,5) AND REF(MA(C,5),1)>=REF(MA(C,5),2) AND YYV1<=YYV2 AND (预量<REF (预量,1) AND 预量<YYV1) AND 买盘1>卖盘1,1,0)) AND CURRBARSCOUNT=28,20,38),COLORFF00FF;
DRAWTEXT(CONST(IF(C<LC AND C<MA(C,5) AND 买盘1<卖盘1 AND 预量>REF(预量,1) AND 预量>YYV1,1,0)) AND CURRBARSCOUNT=28,3,39),COLOR00FF00;
DRAWTEXT(CONST(IF(C<LC*0.96 AND C<MA(C,5) AND 买盘1>卖盘1*1.15 AND 预量>REF (预量,1) AND 预量>YYV1,1,0)) AND CURRBARSCOUNT=28,10,40),COLOR00CCCC;
DRAWTEXT(CONST(IF(C<LC AND MA(C,5)<REF(MA(C,5),1) AND MA(C,10)<=REF(MA(C,10),1) AND 买盘1<卖盘1 AND C<MA(C,5) AND C<MA(C,10)AND 预量>LLV(预量,10),1,0)) AND CURRBARSCOUNT=28,20,41),COLORFFFF00;

DRAWTEXT(CONST(IF((C>MA(C,5) AND C<MA(C,10)) OR (C<=MA(C,5) AND (C>=MA(C,10) OR MA(C,10)>=REF(MA(C,10),1))),1,0)) AND C<LC AND CURRBARSCOUNT=59,90,42),COLORFF77CC;
DRAWTEXT((CONST(IF(CLOSE>=MA(CLOSE,13),1,0))) AND CURRBARSCOUNT=59,80,43),COLORGREEN;
DRAWTEXT((CONST(IF(CLOSE<MA(CLOSE,13) AND C<MA(CLOSE,5),1,0))) AND CURRBARSCOUNT=59,80,44),COLORGREEN;
DRAWTEXT((CONST(IF(CROSS(MA(CLOSE,13),CLOSE),1,0))) AND CURRBARSCOUNT=49,90,45),COLORGREEN;
DRAWTEXT((CONST(IF(C>=MA75,1,0))) AND CURRBARSCOUNT=49,80,46),COLORGREEN;
DRAWTEXT((CONST(IF(C<MA75,1,0))) AND CURRBARSCOUNT=49,80,47),COLORGREEN;

『叁』 通达信 wvad指标源码

通达信的指标源码追问你应该问一下相关的不满或者自己熏一下有个

『肆』 股票指标公式

六脉神剑:

丹田能量:EMA(C,55)COLORMAGENTA,CIRCLEDOT;
少商剑:EMA(C,13),COLORRED,LINETHICK2;
商阳剑:EMA(EMA(C,13),2);
中冲剑:EMA(EMA(EMA(C,13),2),2);
关冲剑:EMA(EMA(EMA(EMA(C,13),2),2),2);
少冲剑:EMA(EMA(EMA(EMA(EMA(C,13),2),2),2),2);
少泽剑:EMA(EMA(EMA(EMA(EMA(EMA(C,13),2),2),2),2),2);
IF(少商剑<REF(少商剑,1),少商剑,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(商阳剑<REF(商阳剑,1),商阳剑,DRAWNULL),COLORYELLOW;
IF(中冲剑<REF(中冲剑,1),中冲剑,DRAWNULL),COLORYELLOW;
IF(关冲剑<REF(关冲剑,1),关冲剑,DRAWNULL),COLORYELLOW;
IF(少冲剑<REF(少冲剑,1),少冲剑,DRAWNULL),COLORYELLOW;
IF(少泽剑<REF(少泽剑,1),少泽剑,DRAWNULL),COLORYELLOW;

坐轿子:

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
开始控盘:IF(A10,5,0),LINETHICK1,COLORYELLOW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;

『伍』 秒杀一切妖股指标公式源码是什么

如下:

{百底公式1}

{AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

顶1:=REFDATE(REF(HHV(H,100),5),DATE);

底1:=REFDATE(REF(LLV(L,100),5),DATE);

中1:=((顶1)+(底1))/2;

顶:IF(AB>0 AND AB-BA<=0,顶1,顶1),COLOR00FF00;

中:IF(AB>0 AND AB-BA<=0,中1,中1),COLORWHITE;

底:IF(AB>0 AND AB-BA<=0,底1,底1),COLORYELLOW;

DRAWTEXT(ISLASTBAR,(顶),STRCAT('',CON2STR(顶,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(中),STRCAT('',CON2STR(中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(底),STRCAT('',CON2STR(底,2))),COLORWHITE;

{百底公式2}

N:100 NODRAW ;

高:IF(CURRBARSCOUNT<=N,CONST(HHV(H,N)),DRAWNULL),COLORGREEN ;

低:IF(CURRBARSCOUNT<=N,CONST(LLV(L,N)),DRAWNULL),COLORYELLOW;

NOTEXT中:低+(高-低)/2 COLORWHITE;

{涨幅:(C-低)/低*100 NODRAW COLORFF00FF;}

涨幅:((C-低)/(高-低))*100 NODRAW COLORFF00FF;

涨天数:LLVBARS(L,100)COLORWHITE NODRAW;

{跌幅:((C-高)/高)*100 NODRAW COLORD9D919;};

跌幅:((C-高)/(高-低))*100 NODRAW COLORD9D919;

跌天数:HHVBARS(H,100)COLORWHITE NODRAW;

DRAWTEXT(ISLASTBAR,(高-(高-低)/50),STRCAT('',CON2STR(高-(高-低)/50,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(NOTEXT中),STRCAT('',CON2STR(NOTEXT中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(低),STRCAT('',CON2STR(低,2))),COLORWHITE;

MA5:MA(C,5),COLORYELLOW;

NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;

振幅:((高-低)/低)*100 NODRAW COLORGREEN;

均周月:INBLOCK('均周')AND INBLOCK('均月') COLORWHITE NODRAW;

逃周月:INBLOCK('逃周')AND INBLOCK('逃月')NODRAW COLORYELLOW;

{VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.01,'高抛'),COLORFFFFFF;

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB = 1),(LOW * 0.99),'低吸'),COLORYELLOW;};

{百底距:=((C-低)/低)*100;

XG1:=BETWEEN(C,低,低*(1+0.03));

盘整天:BARSLASTCOUNT(XG1)NODRAW COLORYELLOW;}

{上涨值:=MA((H+REF(L,1))/2,3);

买进高点:=MA((H+REF(H,1))/2,3);

VAR1:=((O+H+L+2*C)/5)*2-L;

突破买入值:=MA(VAR1,3);{LSS轴点突破买入值}

{下跌值:=MA((REF(H,1)+L)/2,3);

卖出低点:=MA((REF(L,1)+L)/2,3);

VAR2:=((O+H+L+2*C)/5)*2-H;

突破卖出值:=MA(VAR2,3);

次日卖出点:=(上涨值+买进高点+突破买入值+H)/4;

次日买入点:=(下跌值+卖出低点+突破卖出值+L)/4;

均价:=(2*C+L+H/4);

买入价:IF(均价/REF(均价,1)>1,次日买入点*1.01,次日买入点)COLORWHITE NODRAW;

次低价:IF(均价/REF(均价,1)>1,次日买入点/1.0382,次日买入点)NODRAW COLORYELLOW;

卖出价:IF(均价/REF(均价,1)>1,次日卖出点*1.0191,次日卖出点)NODRAW;

必卖价:IF(均价/REF(均价,1)>1,次日卖出点*1.05,次日卖出点)COLORD9D919 NODRAW;}

{AC:=REF(C,1);

涨停K线:=IF((C-AC)*100/AC>=(10-0.01*100/AC),1,0);

跌停K线:=IF((AC-C)*100/AC>=(10-0.01*100/AC),1,0);

STICKLINE(涨停K线,OPEN,CLOSE,2.5,0),COLORYELLOW;

STICKLINE(跌停K线,OPEN,CLOSE,2.5,0),COLORED9564;}

{涨停颜色粉色,完美区分20%10%5%,创业板20200823前10%照样变色}

BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));

XA_1:=IF(DATE<=1200823,1,0);

STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,3,0),COLORED9564;

STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,3,0),COLORED9564;

{STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORYELLOW;{涨停后回落}

{STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORED9564;{跌停后回升}

{Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;}

{DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLORYELLOW;

DRAWTEXT_FIX(1,0.00,0.06,0,'主营业务:')COLORWHITE;

DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORWHITE;

DRAWTEXT_FIX(1,0.00,0.12,0,'公司亮点:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.12,0,EXTERNSTR(0,3))COLORYELLOW; }

{流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;}

{涨停统计}

{涨停:=CLOSE/REF(CLOSE,1)>=1.095;

ZTCS:=COUNT(涨停,BARSSINCE(涨停)+1);}

{DRAWNUMBER(涨停,HIGH*1.04,ZTCS),COLORYELLOW;}

{GZT1:=STRCAT('共涨停: ',CON2STR(ZTCS,0));

GZT2:=STRCAT(GZT1,'次');

SSTS1:=STRCAT('上市: ',CON2STR(FINANCE(42),0));

SSTS2:=STRCAT(SSTS1,'天');

NTZZT1:=STRCAT('距今:',CON2STR(CONST(BARSLAST(涨停)),0));

NTZZT2:=STRCAT(NTZZT1,'天有涨停');

ZTTJ1:=STRCAT(SSTS2,GZT2);

ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);

ZTTJ:=STRCAT('涨停统计:',ZTTJ2);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.18,0,ZTTJ),COLORWHITE;}。

『陆』 请按照下面指标源码做个选股公式,谢谢!

VOLUME:=VOL;
MA1:=MA(VOLUME,5);
启动:= (MA1+MA1)>VOLUME;
买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;
选股:(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;

『柒』 通信达公式问题,超强组合指标公式,谁可以解释一下。我看不明白,源代码如下

{波段线}
VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
{AK: EMA(VAR6,2)*1.22;
AD1: EMA(AK,2);
AJ: 3*AK-2*AD1;
DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;}
{金手指}
RA:=LLV(LOW,35);
RB:=HHV(HIGH,30);
RC:=EMA((CLOSE-RA)/(RB-RA)*4,4)*19;
近日均价:=MA(CLOSE,5),COLORYELLOW,LINETHICK2;
DRAWICON(RC<6 AND 100*(HHV(HIGH,19)-CLOSE)/(HHV(HIGH,19)-LLV(LOW,19))>97,100,11);
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
ZL:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
SH:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
BT1:=CROSS(RSI1,25);
BT2:=CROSS(ZL,SH) AND ZL<-10;
BT:=FILTER(COUNT(BT1 OR BT2,3)>=2,3);
BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),3,1)*100;
VARF:=MA(VARE/10,3);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
MA(IF(LOW<=VAR10,(VARF+VAR11*2)/5,0),3);
VAR1B:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2B:=SMA(ABS(LOW-VAR1B),13,1)/SMA(MAX(LOW-VAR1B,0),10,1);
VAR3B:=EMA(VAR2B,10);
VAR4B:=LLV(LOW,33);
VAR5B:=EMA(IF(LOW<=VAR4B,VAR3B,0),3);
{主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B,0),COLORRED;}
STICKLINE(VAR5B>REF(VAR5B,1),0,VAR5B*2,2,0 ),COLORYELLOW;
洗盘:IF(VAR5B<REF(VAR5B,1),VAR5B,0),COLORLIGREEN;
VARR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARR2:=SMA(ABS(LOW-VARR1),13,1)/SMA(MAX(LOW-VARR1,0),10,1);
VARR3:=EMA(VARR2,10);
VARR4:=LLV(LOW,33);
VARR5:=EMA(IF(LOW<=VARR4,VARR3,0),3);
STICKLINE(VARR5>REF(VARR5,1),0,VARR5,2,0 ),COLORGREEN;
STICKLINE(VARR5<REF(VARR5,1),0,VARR5*2,2,0),COLORRED;
找主力吸筹提款:VARR5>REF(VARR5,4) {AND C>REF(C,1)},COLORMAGENTA;
VAR2C:=(HIGH+LOW+CLOSE*2)/4;
VAR3C:=EMA(VAR2C,7);
VAR4C:=STD(VAR2C,7);
VAR5C:=(VAR2C-VAR3C)*100/VAR4;
VAR6C:=EMA(VAR5C,3);
{WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
MM:HHV(WW,3),COLORFF3333;}
AAA:=AMOUNT/VOL/100;
主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B*1.5,0),COLORRED,LINETHICK2;
{吸筹}
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,6,1),COLORRED;
VARY2:=REF(LOW,1);
VARY3:=SMA(ABS(LOW-VARY2),3,1)/SMA(MAX(LOW-VARY2,0),3,1)*100;
VARY4:=EMA(IF(CLOSE*1.3,VARY3*10,VARY3/10),3);
VARY5:=LLV(LOW,30);
VARY6:=HHV(VARY4,30);
VARY7:=IF(MA(CLOSE,58),1,0);
VARY8:=EMA(IF(LOW<=VARY5,(VARY4+VARY6*2)/2,0),3)/618*VARY7;
VARY9:=IF(VARY8>100,100,VARY8);
吸筹2:STICKLINE(VARY9>-120,0,VARY9/3,2,1),COLORMAGENTA;
LCC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCC,0),4.1,1)/SMA(ABS(CLOSE-LCC),4.1,1)*100,COLORYELLOW,LINETHICK1;
黄买:FILTER((REF(CLOSE,2)<CLOSE AND RSI<25),7),COLORYELLOW;
STICKLINE(黄买,0,-40,10,1),COLORYELLOW;
黄卖:=FILTER((REF(CLOSE,2)>CLOSE AND RSI>80),7);
STICKLINE(黄卖,100,82,10,0),COLORBLUE;
红买:FILTER(CROSS(RSI,11),7),COLORRED;
STICKLINE(红买,0,-30,6,0),COLORRED;
红卖:=FILTER(CROSS(89,RSI),7);
STICKLINE(红卖,100,88,8,0),COLORCYAN;
绿买:FILTER(CROSS(RSI,20),7),COLOR00FF00;
STICKLINE(绿买,0,-20,6,0),COLORMAGENTA;
绿卖:=FILTER(CROSS(80,RSI),7);
STICKLINE(绿卖,100,94,6,0),COLOR00FF00;
★遵守纪律★:100,COLORRED;
★交易之魂★:100,COLORRED;
ZLC:= EMA((WINNER(CLOSE) * 70),3);
SHC:= EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
主力控盘: ((ZLC / (ZLC+ SHC)) * 100),COLOR00FFFF,LINETHICK2;
上限: HHV(主力控盘,20),COLORGREEN,LINETHICK2;
下限: LLV(主力控盘,20),COLORRED,LINETHICK2;
中线:(上限 + 下限)/2,COLORYELLOW,POINTDOT,LINETHICK2;
{60,LINETHICK4,POINTDOT,COLORYELLOW;}
{10,LINETHICK4,POINTDOT,COLORFF00FF;}
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,30,0,4,0),COLOR770077;
STICKLINE(A1,30,0,3,0),COLOR990099;
STICKLINE(A1,30,0,2,0),COLORBB00BB;
STICKLINE(A1,30,0,1,0),COLORWHITE;
STICKLINE(A1,30,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,36,'满仓'),COLORRED;
DRAWTEXT(A1,36,'满仓'),COLORRED;
AK: EMA(VAR6,2)*1.22;
AD1: EMA(AK,2);
AJ: 3*AK-2*AD1;
DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;
WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
MM:HHV(WW,3),COLORFF3333;
DRAWTEXT(BT1,0,'□'),COLORYELLOW;
DRAWTEXT(BT,0,'■'),COLORYELLOW;
DRAWICON(CROSS(85,RSI1),102,15);{饭跑跑}
DRAWICON(CROSS(RSI1,25),10,26);{金钻}
DRAWICON(CROSS(ZL,SH) AND ZL<-10,20,24);{蓝钻}
DRAWICON(CROSS(BIAS,-12),-10,13);{BIAS买点};

『捌』 通达信pbx指标源码

通达信PBX 指标源码如下

PBX1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;

PBX2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;

PBX3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;

PBX4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;

PBX5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;

PBX6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;

阅读全文

与霸王指标公式源码相关的资料

热点内容
货币基金投资理财入门 浏览:807
金融公司赚点还是利率 浏览:457
中小企业内源融资规模 浏览:129
山东融资贷款申请报告公司 浏览:102
理财上什么叫万份收益 浏览:345
融资租赁纠纷的起诉 浏览:282
股指期货的有效止盈止损策略 浏览:444
世界最大贵金属提炼商 浏览:533
境外汇款附言怎么填 浏览:882
外汇牌价澳元走势图 浏览:658
科达股份新股东 浏览:31
金蝶k3月末调汇汇率 浏览:749
杠杆交易计算 浏览:819
螺丝刀属于斜面还是杠杆 浏览:714
中国弃楼市保汇率 浏览:480
杠杆工具的区别 浏览:108
付给境外的佣金代扣代缴增值税 浏览:224
哪个上市公司持有上海新升股份 浏览:292
2017杠杆大宗商品 浏览:327
中国电信集团阳光采购 浏览:627