导航:首页 > 股市基金 > 大牛副图指标源码

大牛副图指标源码

发布时间:2023-09-21 05:22:29

『壹』 求高手帮忙编写一个选股公式;“通达信”软件用。 要求:“必买”选入; 原副图指标公式源码如下:

RSV:= (((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K001:=SMA(RSV,3,1);
D001:=SMA(K001,3,1);
J001:=((2.5 * K001) - (3 * D001));
VAR1001:=ZIG(3,14);
VA2001:=EMA(EMA((WINNER(CLOSE) * CLOSE),3),3);
控筹:=(((VA2001 - REF(VA2001,1)) / REF(VA2001,1)) * 1000);
HUOL:= REF(VAR1001,2) > REF(VAR1001,1) AND VAR1001 > REF(VAR1001,1) AND 控筹 > REF(控筹,1) AND J001 > REF(J001,1);
准备买:= IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK1 ;
必卖: IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK1;
必买: REF(准备买, 1) AND HUOL;
{
你提供的公式是可以直接选股的,是很多的人在用的抄底公式(必买),其中用到未来函数,所以,往往买入后买点又消失了,造成了损失。很多人对包含未来函数的公式不敢用。
为此,我将公式又加了一个限制,前一天出现买入(准备买)信号,当天止跌后买入,经过比较长的一段时间的验证,准确率很高,即使买入后又调整了,幅度也非常有限。
选股时: 买入 等于 1
}

『贰』 股市当中有哪些好用的指标,带源码的

指标不是万能的,不是万能钥匙,灵丹妙药,指标五花八门,林林总总,不计其数。每一类指标只能反映股票运行规律的一个侧面。

我自以为是的适合自己的好用的主图指标如下:

DRAWKLINE(H,O,L,C);

涨停1:=(C/REF(C,1))>=1.095 AND (C/REF(C,1))<=1.105;

STICKLINE(涨停1,O,C,4,0),COLORYELLOW;

涨停2:=(C/REF(C,1))>1.105 AND (C/REF(C,1))<=1.195;

STICKLINE(涨停2,O,C,4,0),COLORLIRED;

涨停3:=(C/REF(C,1))>1.195 ;

STICKLINE(涨停3,O,C,4,0),COLORMAGENTA;

EXPMA17:EXPMEMA(C,17)COLORMAGENTA LINETHICK2;

MA55:MA(C,55) COLORWHITE;

MA89:MA(C,89)COLORYELLOW ;

MA144:MA(C,144) COLORRED LINETHICK2;

CCL:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DDL:=DMA(CLOSE,CCL);

上:=(1+7/100)*DDL,DOTLINE,COLORGREEN;

下:=(1-7/100)*DDL,DOTLINE,COLORGREEN;

中:=(上+下)/2,DOTLINE,COLORGREEN;

上上:=EMA(上,181),DOTLINE,COLORRED;

下下:=EMA(下,181),DOTLINE,COLORRED;

中中:=EMA(中,181),DOTLINE,COLORRED;

DRAWICON(上>=上上,上上,17);

主十增仓:10*WINNER(CLOSE*0.9)*8,NODRAW COLORYELLOW;

十换手:SUM(VOL/CAPITAL*100,10),NODRAW COLORWHITE;

ER:=V/FINANCE(7)*100;

MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));

T1T:=BARSLAST(C>MAXCYC*POW(1.1,0.9));

T2T:=BARSLAST(C<maxcyc*pow(1.1,-0.9)); p=""> </maxcyc*pow(1.1,-0.9));>

T3T:=CROSS(T1T,T2T) OR CROSS(T2T,T1T) OR BARSSINCE(T1T+1)=0 OR BARSSINCE(T2T+1)=0 OR BARSCOUNT(C)=0;

T4T:=REF(MAXCYC,BARSLAST(T3T));

主力盈利:LN(C/T4T)/LN(1.1)*10,NODRAW;

{盈利天:BARSLASTCOUNT(主力盈利>0) COLORMAGENTA,NODRAW;}

获利比例:WINNER(CLOSE)*100,NODRAW;

DRAWICON(获利比例>0 AND 获利比例<=2,L*0.98,9);

DRAWICON(获利比例>2 AND 获利比例<=5,L*0.98,23);

P1:=90;

AO:=P1+(100-P1)/2;

BO:=(100-P1)/2;

CCO:=COST(AO);

DDO:=COST(BO);

筹码集中度:(CCO-DDO)/(CCO+DDO)*100/2,COLORRED,NODRAW;

DRAWICON(获利比例>80 AND 筹码集中度<10,L*0.98,25);

翻倍:=REFDATE(REF(LLV(LOW,90),3),DATE)=LOW AND (CLOSE-LOW>0-CLOSE OR OPEN-LOW>CLOSE-OPEN);

STICKLINE(翻倍,H,H*1.2,2,0),COLORLIRED;

DRAWTEXT(翻倍,H*1.2,'机会来了'),COLORYELLOW;

DRAWTEXT(翻倍,H*1.15,'坚决持有'),COLORCYAN;

DRAWTEXT(翻倍,H*1.1,'后市暴涨'),COLORMAGENTA;

N:=1.5;

M:=3;

DIFF:=EMA((EMA(CLOSE,N*12)-EMA(CLOSE,N*26))/EMA(CLOSE,N*26)*1000,M);

DEAF:=EMA(DIFF,N*9),COLOR000088;

加仓:IF(DIFF>=REF(DIFF,1) AND DEAF<ref(deaf,1),diff,drawnull),colorlired,nodraw; p=""> </ref(deaf,1),diff,drawnull),colorlired,nodraw;>

短线出局:=IF(DIFF REF(DEAF,1),DIFF,DRAWNULL),NODRAW;

STICKLINE(加仓 ,C,C*1.0015,8,0),COLORYELLOW;

在告诉你答案之前,先简短的讲讲我的经历吧!十多年前,我是世界500强企业的一名职员。通过自学,考试后现在转行为证券公司的一名投顾。在我转行之前也是到处找资料学习。相关的书籍啊,指标啊等等,但掌握了一些基础知识后发现即使学会了这些东西还是远远不能在这个市场上生存的。通过认真思考我发现,如果做投资没有自己的交易体系,那是很危险的一件事。在自己的交易体系建立之前,我做过外汇,做过权证,做过商品期货,做过期权,当然也有股票。现在从业了,所以也就只是做做股票的模拟盘。所以对于指标类的东西还是有所发言权的。言归正传,下面来回答一下你的问题吧!

1.如果你真的想在这个投资市场上畅意的行走,你首先应该建立自己的交易体系。

2.在你建立交易体系之后,我现在正式回答你的问题。正常情况下,你只需要认真研究系统默认的几个指标就可以了,K线,均线,量,KDJ,MACD就这几个,其它杂乱的指标都是通过这几个基础指标编辑演变而成的,因为是手机截图,所以这里截了两个图,如果需要操盘,建议最好是用电脑。

3.K线,K线就是红绿柱,他代表最高价,最低价,开盘价和收盘价。在这里我就不详细赘述了。

4.均线,均线分日,月,周,季,年均线等。那要看你是什么周期,比如日均线m5就是五天内的平均价,也就是五日均线。M10就是十天均线等等。

5.量,量就比较复杂一点,常常需要配合其他指标使用,它代表成交量或成交额。周期也是和均线一样。

6.MACD和KDJ,同样需要结合周期来使用,最常见的就是金叉和死叉,但是也需要结合市场环境来看。


给大家一个去掉不适合自己参与的过滤选股器吧,懂代码的可以自己修改,不懂得那就直接用,有几个参数最好自己做一下修改,比如,股价,交易密度,等等。

它的功能是选出适合自己的带有涨停板的活跃股,他不是操作的依据,只是帮你过滤掉那些不适合参与的股票,每天盘后下载数据,复盘选股,他不适合最预警,只适合复盘高效选股。

仅供参考(通达信使用者)

公式名称:去掉无效选股

参数:N=2:2000:60(周期数)

N1=1:200:3(涨停板个数)

SS=2:2000:50(股价)

NN=2:30:15(交易密度)


ENTERLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,20));{这是一个均线自动交易代码暂时先保存着以备后用}

EXITLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,3));{这是一个均线自动交易代码暂时先保存着以备后用}

ZTTJ1:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));

ZTTJ:=(CLOSE>=ZTPRICE(REF(CLOSE,1),IF(FINANCE(3)=3,0.2,0.1)));

ZTTM:=COUNT(ZTTJ,N)>=N1;

AR2:=EVERY(ZTTJ,2);

AR3:=COUNT(AR2,60)>=1;

RZ1:=INBLOCK('壳资源')=0; RZ2:=INBLOCK('商誉减值')=0; RZ4:=INBLOCK('风险品种')=0;

RZ6:=INBLOCK('细分龙头')=1; RZ7:=INBLOCK('已高送转')=0;

{通达信去掉创业板*ST} S1:=IF(CODELIKE(馄'),1,0);

{通达信去掉退市股}{去掉不需要的板块}{通达信去掉*、S、ST}

S2:=IF(NAMELIKE('S'),0,1); S3:=IF(NAMELIKE('*'),0,1);

{通达信去掉停牌}

S4:=DYNAINFO(17)>0;

S5:= BETWEEN(FINANCE(7)/10000000,1,400) AND FINANCE(7)*C/100000000<360 AND C<ss p="" ;

{去掉融券融资 AND S6}

S6:=FINANCE(52)=0;

S7:=IF(CODELIKE(鬈'),0,1);{通达信去掉科创板}

S10:=FINANCE(30)>=-5;

S12:=DYNAINFO(39)<500;

S13:=SUM(DYNAINFO(37),20)>0.2;

S14:=FINANCE(30)/FINANCE(20)*100>-50;

ST:S2 AND S3 AND S4 AND S7 AND RZ4 AND S13 AND ZTTM AND C<ss;{and p="" s1}

AA1:=C/REF(C,1)>1.03 AND C<ss p="" s7;{强势选股}

AB1:=FROMOPEN*NN;

AB2:=DYNAINFO(50)>AB1;

S11:=IF(AB2,AA1,DRAWNULL);

大家好,给大家分享一个监测庄家动向的指标——猎庄擒牛。指标通过对庄家资金的监测,可以捕捉到庄家何时进场拉升,何时出货离场。洞察到庄家的这些动向之后,散户猎庄擒牛并不只是说说而已。

“猎庄擒牛”指标要点:

一、指标提示“庄家出现”信号时,表明监测到此处有庄家大资金进场,行情即将开启拉升,可跟进建仓。

二、指标提示“庄家出货”信号时,表明监测到此处庄家在进行筹码派发,应果断止盈离场,落袋为安。

效果图:

“猎庄擒牛”主要作用就是对庄家大资金动向的监测,从而给出预警信号。当然指标还有其它关于筹码和趋势的信号判断,这里就不做过多讲解,大家拿到后可以去慢慢摸索。

大道至简,简单有效不要复杂。股市中最有效的技术指标就是那些最贴近市场本质的数据跟踪指标,我最常用的就是K线,均线,MACD和量能及均量线,够用了。

在一个多变复杂的市场中,越简单反而才是越有效,过于复杂的技术工具适应能力太差。

通达信精准指标——趋势布林线主图+神针起爆副图+源码 给大家分享一个趋势布林线主图,搭配神针起爆副图,适用于短线和中长线,是基于系统布林线而研发的,比系统自带的更加精准。 主图当出现红色箭头为建仓信号,当出现绿色箭头为减仓或者平仓信号。 副图红色趋势为上升趋势,绿色趋势为下跌趋势,红色趋势变为绿色交叉点为减仓信号。 绿色趋势变为红色为建仓信号,出现神针起爆红柱可作为启动点和建仓点。

主副图点位一一对应,产生共振。 源码

这套指标主要利用主副图共振点来进行操作,精准率很高,喜欢的朋友可以关注我的首页,留言指标二字,我会免费分享给大家。

好用的公式有很多,但是适合自己才行!今天我分享几个我自己经常用的公式分享给大家!

擒牛大中短


这个公式主要就是抓买卖点的指标,不含未来函数,可以放心操作!

主力波段吸筹

该公式是精准判断操作位置,依然没有未来函数!

其次,如果大家想炒股,先学习一些基本的炒股知识,并且少量投入,切不可一梭哈。不要迷信技术指标,所谓的指标都是事后才出来的,有精力的可以去看看指标编程,无非都出自于成交量、成交额、均线等等,所以都是滞后的。简单的K线、成交量、2条均线,辅助参考判断即可。技术指标越复杂,越难以付诸实施。

所以,还请大家不要迷恋技术指标,我曾经花了1年多的时间研究、编写各种技术指标,到现在,我已经放弃了,只留了交易软件里面最原始的指标,做辅助判断而已,记住只是辅助判断。还请大家不要走弯路,一入股市深似海,到处都是坑,切记!!!

这个我认为因人而异,毕竟适合自己的指标才是好指标。这里我们来分享下我常用的指标

第一,均线,均线是时候非常实用的指标,无论是短线,中线,长线都非常实用。

(1)如果是短线,5日均线就够了。5日均线比较神奇。

①当K线从5日均线下方上穿5日均线,而且均线开始拐头,结合量能,底部放量,那么短线就可以把我了,而且是超短机会。基本都有不错的收益。

②当市场均线多头排列,只要K线在5日均线上方,沿着5日均线上行,那么也是一个持仓的机会。

(2)中线,中线一般就是看20日均线,这个均线比较实用,也称为万能均线,只要K线站稳在20日均线上方,而且拐头向上,结合筹码,筹码低位单峰,中线就可以把握。

(3)长线,长线就是60日均线上穿120日均线,而且趋势上行。

第二,MACD,领略到精髓,赚钱非常简单。

1、 MACD在0轴上方——每发生一次金叉,股价将创新高,但是二次金叉不要追。2、 MACD在0轴下方——每发生一次死叉,股价将创新低新低后可以适当的补仓。3, MACD在0轴上方——金叉死叉次数越多越好、牛股,4,, MACD在0轴下方——金叉死叉次数越多越差、熊股。5,MACD水下两次金叉,第二次金叉就是买入机会。6.MACD的黄白两线不能和柱状形成背离,背离则会产生行情反转。

好了我就分享了我常用的这两个希望对大家有帮助。


如果想听实话,我就告诉你。最好用的指标是:K线、成交量(手)、均线和MACD。其它指标都可以忽略。

你进入丛林,容易绕花眼睛,七选八选-选个漏眼。其实最显眼的就是最好的。

『叁』 请求高手把这个通达信指标改成公式(1)短牛大牛(2)短牛中牛大牛(3)短牛各三个选股公式

您好,难听的话说前头,这个指标有未来函数。最好别用。但是我还是把指标改好了,短牛中牛大牛,自己选股的时候组合一下就好了。对了,通常含有未来函数的指标都有很多无用的代码,恕我私自把没用的代码都删除了。

再说一次,有未来函数的话,信号会漂移的。

VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);

UP:DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
DOWN:DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;

BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
DRAWTEXT(BT,3,'短牛'),COLOR0000FF;

TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;

HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:= REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;

ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,9,0.2,0),COLOR00FF00;
DRAWTEXT(ST,9,'卖');

短牛:BT;
中牛:TJ1;
大牛:TJ2;

『肆』 懂牛共振追涨指标公式源码

牛共振追禅碧涨指标是一种用于股票分析的技术指标,可以用来判断股票价格的涨跌趋势和市场热度。其计算公式如下:
牛共振追涨指标 = (收盘价 - N日前的最低价) / (N日前的最高价 - N日前的最低价) * 100
其中,N代表计算周期,春袭李收盘价为当日收盘价,N日前的最高价和最低价分别为过去N天中的最高价和最低价。
以下是使用Python语言实现牛共振追涨指标的源码:
def get_bull_resonance(df, n):
"""

计算牛共振追涨指标

:param df: 包含股票收盘价的数据框

:param n: 计算周期

:return: 牛共振追涨指标

"""

df['min_price'] = df['close'].rolling(n).min() # 计算N日内的最低价

df['max_price'] = df['close'].rolling(n).max() # 计算N日内的最高价

df['bull_resonance'] = (df['close'] - df['min_price']) / (df['max_price'] - df['min_price']) * 100 # 计算牛共振追涨指标
return df['bull_resonance']
使用该代码可以计算股票的牛共振追涨指扒迟标,其中参数df为包含股票收盘价的数据框,n为计算周期。函数返回值为牛共振追涨指标。

『伍』 大盘副图指标,能显示所以大盘的副图指标

指数:INDEXC,NODRAW;
_:INDEXC-REF(INDEXC,1),NODRAW;
沪深:"000300$CLOSE",NODRAW;
__:"000300$CLOSE"-REF("000300$CLOSE",1),NODRAW;
五日:EMA(INDEXC,5);
三十日:EMA(INDEXC,30);
六十日:EMA(INDEXC,60);
大盘: DRAWKLINE(INDEXH,INDEXO,INDEXL,INDEXC);
{画线}
IF(三十日>REF(三十日,1),三十日,DRAWNULL),COLORRED,LINETHICK2;
IF(六十日>REF(六十日,1),六十日,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
{上证指数K线副图指标}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
上证:"999999$C",COLORWHITE,NODRAW;
_±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
五:MA("999999$C",5),COLORWHITE;
十:MA("999999$C",10),COLORYELLOW;
二十:MA("999999$C",20),COLORMAGENTA;
六十:MA("999999$C",60),COLORGREEN;

『陆』 通达信 bsqj副图指标 是什么意思

这是通达信系统系统自带的指标,标出了买卖区间;

源码如下:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR001050;
STICKLINE(买线<卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR404050;
DRAWKLINE(H,O,L,C);
指导:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
界:=MA(CLOSE,27);
B买:IF(CROSS(指导,界) OR CROSS(买线,卖线),C,DRAWNULL),COLORMAGENTA,NODRAW;
持仓:IF(买线>=卖线,C,DRAWNULL),COLORRED,NODRAW;
S卖:IF(CROSS(界,指导) OR CROSS(卖线,买线),C,DRAWNULL),COLORLIGRAY,NODRAW;
空仓:IF(买线<卖线,C,DRAWNULL),COLORGREEN,NODRAW;
DRAWICON(CROSS(买线,卖线),L,1);
DRAWICON(CROSS(卖线,买线),H,2);

表明的意思如下:

买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
当满足条件买线>=卖线时,在日期日0日内最高价的最高值和日期日0日内最低价的最低值位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR001050
当满足条件买线<卖线时,在日期日0日内最高价的最高值和日期日0日内最低价的最低值位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR404050
K线
指导赋值:(收盘价的4日指数移动平均+收盘价的6日指数移动平均+收盘价的12日指数移动平均+收盘价的24日指数移动平均)/4的2日指数移动平均
界赋值:收盘价的27日简单移动平均
输出B买:如果指导上穿界ORCROSS(买线,卖线),返回收盘价,否则返回无效数,画洋红色,NODRAW
输出持仓:如果买线>=卖线,返回收盘价,否则返回无效数,画红色,NODRAW
输出S卖:如果界上穿指导ORCROSS(卖线,买线),返回收盘价,否则返回无效数,画淡灰色,NODRAW
输出空仓:如果买线<卖线,返回收盘价,否则返回无效数,画绿色,NODRAW
当满足条件买线上穿卖线时,在最低价位置画1号图标
当满足条件卖线上穿买线时,在最高价位置画2号图标

注:实际上它也是通过平均线相交来标注买卖点的;

『柒』 超牛指标,请高手加一个同时满足“短牛”“中牛”“大牛”的选股公式

闪牛分析:转载,仅供参考!
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
短牛:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
中牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
大牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
选三牛合一:短牛+中牛+大牛=3;

『捌』 通达信指标公式改为选股公式,帮忙看下是否有未来,要求分别选出,“短牛”“中牛“大牛”3个选股公式。

MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
大牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;

MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
中牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;

VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
短牛:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);

有划线函数DRAWLINE潜在的未来函数谨慎使用

『玖』 编写一个通达信选股公式,MACD周线金叉

选股公式如下,选股周期选择周线,

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

XG:BARSLAST(CROSS(DIF,DEA))>0 AND DIF>DEA;

阅读全文

与大牛副图指标源码相关的资料

热点内容
原油期货软件哪个好 浏览:836
阜阳融资商业计划书 浏览:206
心理罪参股的上市公司 浏览:221
郑州动力煤期货 浏览:164
微理财的收益怎么算 浏览:632
融资发布会主题 浏览:334
容大光电股票 浏览:174
深股通持仓数量什么意思 浏览:270
迪斯尼公司投融资行为分析 浏览:239
证券公司资质查询 浏览:750
银行贷款无房证明 浏览:350
股票索赔风险 浏览:826
建设银行有什么理财 浏览:150
达氏集团董事长 浏览:364
玉米期货最低多少钱 浏览:981
融资是否可以卖股权 浏览:761
消费金融公司设立阶段 浏览:382
融资的现状分析与对策 浏览:335
证券投资学股票分析论文 浏览:613
平安证券新人专享63 浏览:448