导航:首页 > 股市基金 > 通达信指标天机泄露

通达信指标天机泄露

发布时间:2024-04-14 09:01:32

Ⅰ 怎么做到自编通达信指标公式只能让对方使用但他不能导出给第三方牟利

炒股朋友一般对通达信软件都非常的熟悉,如果你还是个技术派,那么应该对通达信的公式编写肯定做过研究。利用通达信自带的选股条件或自定义选股条件公式(如均线多头排列、60日缩量、MACD底背离、突破底部横盘等),就可以很方便的利用选股器把符合条件的股票给筛选出来。那么问题来了,通达信并不能对选股模型进行历史数据回测,这样的模型你敢实盘吗?

我经常发现在知乎、股票论坛上看到一些炒股的朋友在问,如何进行交易系统的历史回测。看来大家觉得对模型地数据验证是很有必要的。目前市场上已经有比较好的历史数据回测分析工具,我自己在用的是果仁网,可以回测10年的数据。小编就拿一个常用的均线多头排列的选股公式作为例子,讲一下如何在果仁网实现选股,并对选股模型进行数据回测。

Ⅱ 通达信的道破天机指标,里面只有三条线,红色的,黄色,紫色,很简单

N:=15;
VAR2:=MA(CLOSE,5);
VAR3:=MA(CLOSE,10);
VAR4:=MA(CLOSE,20);
VAR5:=MA(CLOSE,30);
VAR6:=((((VAR2 + VAR3) + VAR4) + VAR5) / 4);
VAR7:=(((VAR6 - REF(VAR6,N)) / REF(VAR6,N)) * 100);
VAR9:=EMA(VAR7,5);
付氏精准:IF(CROSS(VAR7,0),10,0),COLOR99CC99;
稳操胜券:STICKLINE(((VAR7 > REF(VAR7,1)) AND (VAR7 > 0)),0,VAR9,3,0),COLORFF00FF;
STICKLINE(((VAR7 > REF(VAR7,1)) AND (VAR7 < 0)),VAR7,VAR9,3,0),COLOR0000FF;
箱体震荡:STICKLINE(((VAR9 > REF(VAR9,1)) AND (VAR9 < 0)),VAR7,0,3,0),COLORFF0000;
翻转做多:STICKLINE((VAR9 > REF(VAR9,1)),VAR7,VAR9,3,0),COLOR0000FF;
生命禁区:STICKLINE(CROSS(VAR7,0),VAR7,VAR9,3,0),COLORFFFFFF;
股价泥潭:STICKLINE((VAR7 < REF(VAR7,1)),VAR7,VAR9,3,1),COLOR00FF00;
多头回调:STICKLINE(((VAR7 < REF(VAR7,1)) AND (VAR9 > (1 * REF(VAR9,1)))),VAR7,VAR9,5,0),COLOR00EEFF;
STICKLINE((((VAR7 < REF(VAR7,1)) AND (VAR9 > (1 * REF(VAR9,1)))) AND (VAR7 > 0)),0,VAR9,3,0),COLORFF00FF;
生死线:0,COLOR7766CC;
VAR10:=(((CLOSE - MA(CLOSE,58)) / MA(CLOSE,58)) * 100);
VAR11:=((((VAR10 > (1 * REF(VAR10,1))) AND (VAR10 < (0 - 26))) AND (VAR10 > (0 - 40))) * 1.5);
VAR12:=((VOL / CAPITAL) * 100);
VAR13:=LLVBARS(LOW,50);
VAR14:=SUM(VOL,VAR13);
VAR15:=HHVBARS(HIGH,50);
VAR16:=SUM(VOL,VAR15);
VAR17:=(((CLOSE - REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);
VAR18:=((VAR16 / CAPITAL) * 100);
VAR19:=(((CLOSE - REF(OPEN,VAR13)) / REF(OPEN,VAR13)) * 100);
VAR20:=((VAR14 / CAPITAL) * 100);
VAR21:=MA(CLOSE,3);
VAR22:=(REF(CLOSE,2) * 0.865);
VAR23:=(REF(CLOSE,13) * 0.772);
VAR24:=MIN(VAR22,VAR23);
VAR25:=MA(CLOSE,13);
大底:(IF((((((CLOSE - VAR24) / CLOSE) < 0.03) AND (VAR17 < (0 - 35))) AND ((SUM(VAR12,5) / 5) < 1.8)),1,0) * 10),COLORFFFF00;
VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
VAR28:=EMA(VAR27,9);
VAR29:=(2 * (VAR27 - VAR28));
STICKLINE(((VAR27 < (0 - 50)) AND (VAR26 > 7)),0,(0 - 10),3,0),COLORFFFF66;
DRAWTEXT(((VAR27 < (0 - 50)) AND (VAR26 > 7)),(0 - 10),'单边追涨');
DRAWTEXT(大底,8,'大底-成功率95%'),COLORFFFFFF;
DRAWICON((CROSS(VAR9,VAR7) AND (VAR7 > 0)),VAR9,5);
DRAWTEXT((CROSS(VAR9,VAR7) AND (VAR7 > 0)),VAR9,' 逃顶'),COLORWHITE;
KS13:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * (0 - 100));
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
FASTK:=SMA(RSV,3,1);
D:=SMA(FASTK,3,1);
VA1:=SMA(D,5,1);
VA2:=(((CLOSE / MA(CLOSE,40)) * 100) < 76);
VA3:=(((CLOSE / MA(CLOSE,60)) * 100) < 74);
VA4:=(HIGH > (LOW * 1.051));
FNZH:=(VA4 AND (COUNT(VA4,5) > 1));
LC:=((((FNZH AND (VA2 OR VA3)) AND (REF(KS13,1) >= 10)) AND ((REF(KS13,1) / KS13) >= 1.13)) AND ((CLOSE / REF(CLOSE,1)) >= 1.02));
DRAWICON(LC,5,12);
DRAWTEXT(LC,15,'反弹'),COLOR0000FF;
RSI:=REF(CLOSE,1);
VAR58:=((SMA(MAX((CLOSE - RSI),0),6,1) / SMA(ABS((CLOSE - RSI)),6,1)) * 100);
DRAWICON(((REF(VAR58,1) > 85) AND CROSS(84,VAR58)),VAR7,5);

Ⅲ 通达信 macd指标即将金叉的选股公式能写吗

编写即将金叉没问题但是怎么满足即将金叉的条件要说清楚了才好编写。

Ⅳ 通达信自用指标全不见了,是什么原因

Ctrl+F调出公式管理器,点击:公式恢复,选取最近一个或前某个备份,确认看看。

Ⅳ 通达信最强指标公式

公式如下:
DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,Ƈ',0);
锁定因子:MA(LFS,1),COLORWHITE;
换手:100*VOL/CAPITAL,NODRAW,COLORLIGREEN;
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,LINETHICK2;
非主流资金:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORGREEN,LINETHICK1;
收盘价获利比例:WINNER(C)*100,LINETHICK0;
VARF:=TROUGHBARS(3,15,1)<4;
DRAWTEXT( FILTER(VARF=1,5),主流资金*0.90,'★底'),COLORYELLOW;
明天见底:FILTER(VARF=1,5) ,COLORFF00FF,LINETHICK0;
主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW;
散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散户套牢比率:散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
主力控盘比率:主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
市场总量:MA(主力筹码估算+散户筹码估算,13),COLORGREEN,LINETHICK2;
散户警戒:=EMA(散户套牢比率,89),NODRAW;
主力警戒:=EMA(主力控盘比率,89),NODRAW;
{散户坑}
STICKLINE(REF(散户套牢比率,1)>90 AND 散户套牢比率<90,30,0,1,0),COLOR0000FF;
{筹码总量}
筹码总量:IF(市场总量>REF(市场总量,1),市场总量,DRAWNULL),COLOR0066FF,LINETHICK2;
DRAWRECTREL(0,60,240,950,RGB(80,00,100));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.10,0,'■ 主力筹码估算:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.10,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.10,0,主力筹码估算),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.20,0,'■ 主力控盘比率:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.20,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.20,0,主力控盘比率),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.30,0,'■ 散户套牢比率:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.30,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.30,0,散户套牢比率),COLORRED;
DRAWTEXT_FIX(收盘价获利比例>=0,0.0,1-0.61,0,STRCAT(' ■ 收盘价获利比 : ',CON2STR(收盘价获利比例,2))),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.45,0,'■ 锁定因子: 锁定筹码和解锁筹码的相对速度'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.50,0,' 不直接监测锁定筹码多少,但可监测筹码。'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.55,0,'■主流资金:可监控筹码资金的背离,做决策'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.86,0,'■《股金道中》股道股灵子编辑'),COLORLIMAGENTA;
{换手}
F:=MOD(SUM(100*VOL/CAPITAL,0),100);
M:=(SUM(100*VOL/CAPITAL,0)-F)/100,LINETHICK0;
TJ:=FFD:=REF(BARSLAST(TJ),1)+1,LINETHICK0;
DRAWTEXT(TJ,主流资金*0.96,'▲换!'),COLORYELLOW,LINETHICK3;
STICKLINE(TJ,主流资金,主流资金*0.98,0.08,0),COLOR0000FF,LINETHICK1;
HSL:100*VOL/CAPITAL,NODRAW,COLORLIGREEN;
TZHSLJL:=SUM(HSL,FD);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.68,0,'■上次到目前换手率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.68,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.11,0.68,0,TZHSLJL),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.75,0,'■一次换手率 天数:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.75,0,' 天'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.11,0.75,0,FD),COLORYELLOW;
20,POINTDOT,COLORF00FF0;
50,POINTDOT,COLORGREEN;
80,POINTDOT,COLORWHITE;

Ⅵ 通达信天眼主图指标公式是什么

倍量是今日成交量比上昨日成交量的几倍,n是4就是4倍,(4是随便写的没有任何意义)m是划线长度,股票走势图中横坐标轴是时间,想画虚线无法用厘米为单位只能用时间为单位,m是最长的时间范围,30就是30根k线,(这个数值也是随便设置的没有任何意义)
n参数和m参数需要使用这自己决定设置多少请勿使用默认值.

N:=4;
M:=30;
X:=BARSLAST(V/REF(V,1)>N);
AA:IF(X>=0 AND X<=M,REF(C,X),DRAWNULL)DOTLINE,COLORYELLOW;

X0:=BACKSET(REF(C,3)MA(V,3) AND REF(C/REF(C,1)>1.03 AND C>O,3),4);

X1:=X0 AND REF(X0,1)=0;

STICKLINE(X1,H,C,0,0),COLORFF0080;

STICKLINE(X1,O,C,3,0),COLORFF0080;

STICKLINE(X1,L,O,0,0),COLORFF0080;

X3:=BACKSET(LLV(L,3)>REF(C,3) AND REF(X1,3),4);

STICKLINE(X3,REF(C,BARSLAST(X1)),REF(C,BARSLAST(X1)),5,0),COLORFF0080;

X5:=BACKSET(LLV(L,3)
STICKLINE(X5,REF(L,BARSLAST(X1)),REF(L,BARSLAST(X1)),5,0),COLORFF0080;

主图是在K线图上叠加显示,附图是在下方单独显示。

通达信软件是多功能的证券信息平台,与其他行情软件相比,有简洁的界面和行情更新速度较快等优点。通达信允许用户自由划分屏幕,并规定每一块对应哪个内容。至于快捷键,也是通达信的特色之一。通达信还有一个有用的功能,就是“在线人气”,可以了解哪些是当前关注,哪些是持续关注,又有哪些是当前冷门,可以更直接了解各个股票的关注度。

深圳市财富趋势科技有限责任公司是一家资深的证券业高科技企业,致力于证券分析系统和计算机通讯系统的研究开发,自1995年成立以来,经过蓬勃发展,已经成为该行业的典范。其开发的行情源被同行业多企业采用,是目前市场上非常主流的拥有自主开发证券类软件能力的企业。深圳市财富趋势科技有限责任公司在证券行业的著名品牌是“通达信”。

阅读全文

与通达信指标天机泄露相关的资料

热点内容
大桥石化融资 浏览:784
宁波有期货开户吗 浏览:878
796交易所网址 浏览:420
财付通是否是上市公司 浏览:696
理财产品到期当天到账 浏览:574
国盛中心的金融公司 浏览:665
中信证券查询资金账号 浏览:644
新凤鸣集团总裁 浏览:213
2016期货投资报告 浏览:440
300170证券交易所 浏览:198
工行35天理财产品 浏览:738
理财产品是什么时候出现的 浏览:923
闰土股份技改 浏览:230
沃尔核材大宗交易 浏览:835
修改大股东减持的规 浏览:661
理财管理费光大银行 浏览:97
手机银行操作理财 浏览:843
手机银行炒贵金属怎么样 浏览:40
B款人民币理财产品什么意思 浏览:158
港股通汇率费用 浏览:706