导航:首页 > 股市基金 > 通达信五彩柱指标

通达信五彩柱指标

发布时间:2024-05-15 22:31:57

㈠ 通达信指标公式,请改成选股公式:红柱、黄粉柱或黄柱出现 谢谢

1、最佳买入选股:

VAR1:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:=IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:=EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:CROSS(最佳买入,0);

2、斋主全仓:
天:=80,POINTDOT,COLORBLUE,LINETHICK4;
海:=20,POINTDOT,COLORRED,LINETHICK4;
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
斋主全仓:TJ1 AND TJ2 AND TJ0 AND TJ3;

3、财神:
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盘:=3*VARH3-2*VARH4;
财神:CROSS(操盘,VARH3) AND VARH3<2.1 AND C>O;

满意请采纳!

㈡ 通达信zjfz指标指标中,白柱,红柱,黄柱,表示什么

在指标中,“白柱,红柱,黄柱”,分别表示为:

白柱: 当股票价格下跌,满足公式设置的条件(VAR8>-120)时,画深灰色柱状线;

红柱: 当满足公式设置的条件(VAR8>1 和"KDJ的J">1日前的"KDJ的J"和 REF("KDJ的J",1)<2日前的"KDJ的J")时,画红色柱状线;

黄柱:当满足公式设置的条件(VAR8>0.1 和VAR8<1 和"KDJ的J">1日前的"KDJ的J"和 REF("KDJ的J",1)<2日前的"KDJ的J"时,画黄色柱状线。

(2)通达信五彩柱指标扩展阅读:

ZJFZ----指标

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;

VAR4:=EMA(VAR3*10,3);

VAR5:=LLV(LOW,13);

VAR6:=HHV(VAR4,13);

VAR7:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618;

VAR8:=IF(VAR7>500,500,VAR7);

STICKLINE(VAR8>-120,0,VAR8,3,1),COLORGRAY;

STICKLINE(VAR8>1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)

STICKLINE(VAR8>0.1 AND VAR8<1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)

㈢ 请给我个公式吧,选出通达信指标中出现红柱(就是低买=5,买进=1同时出现的个股)

A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
SHORT:=7;
LONG:=19;
RMA:=EMA(CLOSE,SHORT);
NMA:=EMA(CLOSE,LONG);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0);
买进:=(LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
趋势区:=IF((EVERY(DOWN>=REF(DOWN,1),1)),4,2) ;
低买:=CROSS(趋势区,2.1);
XG:低买 AND 买进;

㈣ 通达信软件 MACD指标中柱子值的计算公式

MACD-公式算法
DIFF线 (Difference)收盘价短期、长期指数平滑移动平均线间的差 DEA线 (Difference Exponential Average)DIFF线的M日指数平滑移动平均线 MACD线 DIFF线与DEA线的差,彩色柱状线 参数:SHORT(短期)、LONG(长期)、M天数,一般为12、26、9 公式如下所示: 加权平均指数(DI)=(当日最高指数+当日收盘指数+2倍的当日最低指数) 十二日平滑系数(L12)=2/(12+1)=0.1538 二十六日平滑系数(L26)=2/(26+1)=0.0741 十二日指数平均值(12日EMA)=L12×当日收盘指数 + 11/(12+1)×昨日的12日EMA 二十六日指数平均值(26日EMA)=L26×当日收盘指数 + 25/(26+1)×昨日的26日EMA EMA(Exponential Moving Average),指数平均数指标。也叫EXPMA指标,它也是一种趋向类指标,指数平均数指标是以指数式递减加权的移动平均。各数值的加权是随时间而指数式递减,越近期的数据加权越重,但较旧的数据也给予一定的加权。
差离率(DIF)=12日EMA-26日EMA
九日DIF平均值(DEA)=最近9日的DIF之和/9

柱状值(BAR)=DIF-DEA

MACD=(当日的DIF-昨日的DIF)×0.2 +昨日的MACD

㈤ 通达信,让附图指标的0轴变成实线,能做到吗

首先说明,不同的指标公式具体不同,且不同的思路实现方式不同。你没有说明的你副图公式,所以不好讲明白——有好几种实现方式。
这里以系统提供的MACD为例。这个最简单,也最实用。

问题1,让副图0轴为实线,可以吗?答:可以。
举例,以系统提供的MACD为例,添加一条语句:
G1:0,COLORWHITE;{G1为随意设置的变量,也可以使任何其他不与系统冲突的变量。}
这时候你会发现MACD的0轴变为了实线。

问题2,让0轴上方的线和下方的线的颜色不同,可以吗?答:可以。
【方法一】用COLORSTICK画“彩色”柱状图,如下(仍然以MACD为例):
解释:COLORSTICK,画彩色柱状线,且用不同颜色区分正值、负值。
MACD:(DIF-DEA)*2,COLORSTICK;{你尝试吧COLORSTICK变为COLORRED,你就明白了。}
【方法二】用IF语句,如下(仍然以MACD为例):
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
{MACD:(DIF-DEA)*2,COLORSTICK;}{这条为源语句,改为如下}
MACD:=(DIF-DEA)*2;
MACD1:IF(MACD>=0,MACD,DRAWNULL),COLORRED;{假如为正值则红色}
MACD2:IF(MACD<0,MACD,DRAWNULL),COLORGREEN;{假如为负值则绿色}

阅读全文

与通达信五彩柱指标相关的资料

热点内容
广州鲁银融资租赁有限公司 浏览:49
甘肃信托2013年年报 浏览:483
如何理财投资理财 浏览:453
证券基本分析的主要内容 浏览:703
基金是否属于间接融资 浏览:170
2018哪家银行理财收益高 浏览:518
理财支付宝博时基金怎么关闭 浏览:568
20万适合怎么投资理财 浏览:171
孙慧明持股持仓明细 浏览:218
网上投资理财排名 浏览:899
差旅费报销汇率按哪一天算 浏览:240
证券投资学图形分析 浏览:974
国内浦发外汇汇率 浏览:251
国内奶粉上市公司 浏览:781
黄金期货资金条件 浏览:343
股票交际时间 浏览:529
股票会停盘嘛 浏览:322
股票持仓是什么意思i 浏览:466
理财参考年化净收益率 浏览:338
银行理财市值和份额 浏览:466